Joomla! 1.7

By in Joomla! on 21. Juli 2011

Seit Anfang 2011 steht die Finalversion von Joomla! 1.6 zur Verfügung. Doch leider haben die Entwickler von Templates und Erweiterungen sehr lange für Ihre Anpassungen gebraucht. Dies liegt sicherlich daran, dass die Änderungen zwischen 1.5 und 1.6 erheblich tiefgreifender sind, als es der kleine Versionssprung vermuten lässt. Heute ist nun schon das nächste Update 1.7 erschienen, das wieder einige interessante Neuerungen bietet.

Die Joomla!-Entwickler haben sich damit an den, bei der Freigabe der Version 1.6 bekanntgegebenen Fahrplan gehalten, von nun ab alle 6 Monate eine neue Hauptversion zu veröffentlichen. Die Änderungen sind daher auch nicht so tiefgreifend wie bei Version 1.6, die immerhin 3 Jahre Entwicklungszeit benötigte. Die meisten für Version 1.6 geschriebenen Erweiterungen und Templates sollten daher ohne oder mit kleinen Änderungen auch mit Version 1.7 zusammenarbeiten.

 

Downloads & Informationen

Joomla! 1.7.x – internationale Websitedeutsche Website

Anmerkung: Auf der deutschen Website wird am 25.07.2011 noch keine deutsche 1.7 angeboten. Auf der Seite der Übersetzer gibt es schon die deutschen Sprachpakete und Vollversionen: jgerman.de

Informationen zu 1.7: www.joomla.org/index.php?option=com_content&view=article&id=5381

Wissenwertes: community.joomla.org/blogs/community/1470-need-to-know-17.html

Upgrade von 1.6.5 auf 1.7: docs.joomla.org/Upgrade_1.6.5_to_1.7

Upgradevorgang 1.6.5 auf 1.7 als Screencast: www.youtube.com/watch?v=xY7U9UisLEg

Upgrade von 1.5 auf 1.7: docs.joomla.org/Upgrade_1.5_to_1.7

Deutsches Tutorial zur Migration von 1.5 auf 1.7

Deutsche FAQ zu 1.5 – 2.5

 

Dokumentation zu Joomla! 1.7

Joomla! 1.7 – Das Einsteigerbuch – von Hagen Graf – Juni 2011
Online-Version: cocoate.com/de/j17de

 

Probleme bei der Installation

Problem nach der Installation von Joomla! 1.6

Gleich bei ersten Ausprobieren merke ich, dass nur die Homepage funktioniert. Alle weiteren Seiten werden ohne CSS angezeigt.  Das Einloggen als Administrator funktioniert gar nicht, weil angeblich die Daten falsch sind.

Analyse: Ein Blick auf die URL zeigt, dass hier mehrfach index.php steht. Der Verdacht fällt daher auf die Komponente zur Suchmaschienenoptimierung (SEF), mit der ich auch unter 1.5 meine Probleme habe.

Lösung: Mit einem Editor öffnet man die Datei configuration.php und setzt die Variable “$sef = ’1′” auf “0″. Damit ist die Optimierung abgeschaltet und bei mir funktionierte die Website dann wieder.

 

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

Du kannst folgende HTML-Tags benutzen: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>